Lack of ralink 2561 support

Story: Ubuntu 7.10 - The Best Version.Total Replies: 6
Author Content

Nov 02, 2007
6:21 AM EDT
I is annoying that Ubuntu still lacks rt61 support, as that chipset is readily available in some very cheap adaptors.

However.. rt61 IS available at :


a (generally) reliable source has compiled the CVS driver for gutsy and pronounced it good to go. The driver at ralink itself, and the rt2x00 stable driver apparently have issues with the Gutsy kernel, but, hey -- all you need is one that works, right?


The rt61 WILL be part of the mainline 2.6.24 kernel, on the mad80211 stack. I have the current git version compiled and running on my kernel, jammed into Feisty Fawn (Ubuntu 7.04) on my Mythtv box. There is a brief discription of how to do it in the beta support forum at

One hint -- the rt2x00 folks keep things pretty up to date, so there is a chance that non-ralink compilers in their git branch won't compile. I have had to "unselect" Intel wireless pro driver and Marvel libertas drivers to get through the compile. Not a problem for me, as I want the ralink drivers.

I suspect that the folks doing the Marvel and Intel tress periodically have the same problem with Ralink drivers.


Nov 02, 2007
7:42 AM EDT
dino, the kernel's wireless subsystem has undergone a complete rewrite. The first bits were accepted into the 2.6.22 kernel, and much activity has been occurring since. A lot of drivers had to be rewritten, and the whole works has pretty much been a frenzy. Not only that, but the new wireless subsystem makes it a lot easier to write and maintain Linux wireless drivers, so more hardware vendors are coming on board.

Naturally, the fine folks who read and memorize my every word know these things :) Here's a bit of background:

Executive summary: the good times are just around the corner.

Nov 02, 2007
8:00 AM EDT
>dino, the kernel's wireless subsystem has undergone a complete rewrite.

I know. I'm using the rewritten system, and I'm using the rt61pci driver from the 2.6.24 kernel to come. It was your article that made me want to switch over.

Nov 02, 2007
9:48 AM EDT
Huge problems with 7.10 2 acer 1 compaq

I have to fall back several releases on the kernel to get Xorg to run. Skype is borked (am installing new one now) Flash problems. Devil of a time getting the USB HD to work.

But when I got the updates for my Feisty machine (old HP) it went belly-up too. That was yesterday. That one is getting Linux Mint soon. There was a new kernel version in that update!

We have had such great luck with Ubuntu, this just drives me crazy.


Nov 02, 2007
10:21 AM EDT
Quoting:However.. rt61 IS available at :

I can vouch for the serialmonkey cvs driver, since it works for me on suse 10.3, which comes with a 2.6.22 kernel and no ralink drivers.

Quoting:The rt61 WILL be part of the mainline 2.6.24 kernel
That's great news, I always prefer using something that's in mainline, rather than making a hobby of compiling drivers

Nov 13, 2007
2:10 PM EDT
About eight months ago, I also tried and tried and tried again all sort of rt2561 drivers (Windows via NDISWRAPPER, Linux-stable / CVS, general rt25xx drivers I believe) I could get my hands on, but nothing worked, and after the moment I finally got some 'response' from the software I found out the drivers didn't support WPA at that moment (bummer!), so I gave up. I'm interested if the situation is better now; does WPA work with rt25xx now?

PS I believe I also tried Ubuntu at that moment, but I'm not really sure, it could also have been OpenSuSE.

Nov 13, 2007
6:37 PM EDT
Quoting: I'm interested if the situation is better now; does WPA work with rt25xx now?
I can tell you that things are looking up. I'm happy to report that I'm connected to a wpa-psk wireless access point and surfing the web using only the serialmonkey rt61driver.

Posting in this forum is limited to members of the group: [ForumMods, SITEADMINS, MEMBERS.]

Becoming a member of LXer is easy and free. Join Us!