Cannot see the /home directory on the hdb disc when trying to rsync from my hda disc ...

Forum: LXer Meta ForumTotal Replies: 8
Author Content

Jun 17, 2008
12:04 PM EDT
First the home directory was formatted as a logical NOT a primary partition as I thought it was. I have no idea how this happened, I did, however, run an inplace upgrade from Ubuntu 5.04 to 5.10. Nonetheless, I find it hard to believe that was the cause.

Is it simply not possible to see the home directory on the b drive when it is formatted in such an odd fashion or do I just lack the knowledge?

TIA (by the way see this with a serious tag).

Jun 17, 2008
12:15 PM EDT
primary/logical shouldn't make any difference whatsoever. I often have a mix of both. In case you don't know, a disk can have 4 primary partitions (hdx1-4), one of them can be an extended partition that holds logical partitions (hdx5+). (fairly quick basic overview) Other than that, you just handle them all the same. Just format and mount like any other partition.

Jun 17, 2008
12:36 PM EDT
I do know, that's why I mentioned being perplexed why it ever got to be a logical partition. There may be another problem, because it was NOT seen in an installation where I tried all alternatives to see the directory.. [The partitioning on the b drive is: 1 / ext3 primary 2 extended 5 swap 8 (or 6) ext3 /home.]

Jun 17, 2008
12:47 PM EDT
Weird...almost like the "upgrade" rewrote the partition table on that disk... Can you use it with a plain old cli livecd?

Jun 17, 2008
1:16 PM EDT
Not sure what cli livecd is. Using the Ubuntu 7.10 live cd and install i first tried manual installation, which seemed to stall out when the Advanced button wanted to install some app. Nothing happened.

Later I tried to use the Partition Editor and that too did not work properly. I used to do my partitions on the command line and I thought I always had the option of selecting primary or extended or logical once I created an extended partition. However, I have not tried to upgrade since I loaded 6.06 desktop. It served my needs until recently.

I will do a write up and see if my experiences have been observed by others. For now I will copy to a backup partition on the root directory then transfer over to the home.

This is NOT a very serious issue, since I am leaving 7.10 for 8.04 LTS desktop on my a disc. This was just practice, since I have not been doing much installations since early '07 and those were server versions.

Thanks for the input.

Jun 17, 2008
1:33 PM EDT
I meant cli livecd as in a livecd with a command line to manually work on stuff with. hehe :)

Yeah..whole thing is rather odd...


Jun 17, 2008
3:10 PM EDT
> The partitioning on the b drive is: 1 / ext3 primary 2 extended 5 swap 8 (or 6) ext3 /home.

Well, operating from memory (as I'm still at work in front of a Windows machine), if it's eight, then you should be able to just type mount -t ext3 /dev/hdb8 /whatever_mount_point_you_want and mount the partition. If it's six, then replace hdb8 with hdb6.

I don't use mount all that much, so I may have messed up the syntax, but it looks right.

Jun 17, 2008
4:06 PM EDT

I actually tried something similar, but I used eight whereas it (should || could) be 6. I will try it again later after I check the syntax, because I did something that did not work and it might be more than the wrong digit.

I am working on something else at the moment. If this works I will be happy, but I will settle just preserving the old home directory content. It will be easier to copy my a drive home into b off the root. Then I will upgrade and be done for awhile.

Jun 20, 2008
11:19 AM EDT

Yes I can mount the second (b drive), it's just that having settled on Ubuntu 6.06 so long I forgot the tasks required. That is, i have to create the mount point. The first time I looked the content appeared bogus. However, on the drive I confirmed it was real with mostly empty default directories and for my usual user a linked file that was completely empty.

I now see I have some bigger problems. Suddenly I cannot open a terminal to run as sudo on the b drive. Moreover, adding other terminals also do not work. Of course, I could not unload and reload the Gnome terminal to see if that was the problem. It's not allowed. I have other worries, security issues, but that is going into another post.

I am going to reinstall this time making the home directory a primary drive as it was on my a drive. I cannot attest with absolute certainty that I did not create it as a logical drive. However, this was my newer, larger drive with only Linux. I had no reason to do so. Nonetheless, I cannot say I did not fsck it up myself (that's a file system cleanup tool for those with warped minds, i.e. file system check).

I will report back later.

Posting in this forum is limited to members of the group: [Editors, MEMBERS, SITEADMINS.]

Becoming a member of LXer is easy and free. Join Us!