Word processors

Story: The next document I put together will be done with LyXTotal Replies: 3
Author Content

Nov 08, 2009
4:12 PM EDT
I'd go as far as saying that MS Word and OOo Writer aren't Word Processors anymore. They're more akin to Desktop Publishing but in the process forgot how to process words. They not able anymore to take some words and output a nice document.

Nov 08, 2009
5:50 PM EDT
Quoting:They're more akin to Desktop Publishing

Maybe, but while MS Word may be akin to DTP, it is not usable as DTP. I encountered this last week, when writing some 'report' (not near real DTP, but we want to have WYSIWYG here anyway):

-Made a table, put text / numbers in the table. -Put one photograph in the table, -Put some photographs below the table, -Put some arrows 'on top' of the photographs.

First failure: The arrow can't point to any location on the file. Word uses some grid it seems, like ACAD, but unlike ACAD I haven't been able to simply turn it of. Second failure: AFAIK those arrows can only be selected by means of using the mouse.

-Put some textboxes on the other end of the arrows.

Third failure: I need to insert 'newlines' before I can put a textbox on top of the photograph.

Then, while working with it, came the fourth failure:

Accidentaly I inserted 'large' empty footers taking up 10 lines per page, but I hadn't noticed. Word doesn't provide a way for its user to see that those 10 empty lines where you can't type anything / where the table stops and resumes on the next page, contain a footer. It was 'by accident' again that I found out these were footers. Also the formatting marks didn't reveal this.

Then the fifth failure: When trying to just make only two chars bold, the entire document is put in bold because the 'style' is automatically updated to reflect that I made two symbols bold, and now Word wants to make the whole document bold. I didn't ask for this, but it's not to hard to solve.

Sixth failure: This takes minutes to undo! Word seems to hang. Why? Well, because it starts messing around with the arrows, textboxes, tables, photographs and text in the tables: putting it back and forth to other pages.

Seventh failure: Word doesn't provide a 'stop' button. I had the pleasure to work with Maple on RH Linux in 2001, probably my first real world experience with Linux. Whatever you commanded maple to do, like (a+b+c+d)^200, still whenever you hit the 'stop' button it stops within ten milliseconds or so. It's never 'not responding'.

Eighth failure: When trying to kill it, it's not responding.

I believe Kword uses frames, that would solve most of the problems above. OOo I don't know, haven't been using it to write reports (I work at a 'proprietary only' firm).

Nov 08, 2009
6:16 PM EDT
I believe if you hold Ctrl or Alt while dragging then you can drag objects without using the grid and place them freely.

Nov 09, 2009
5:59 AM EDT
I knew it! I knew MS Word was perfect and it's just me the user that's to blame. Thanks Sander! Ctrl BTW rotates the arrows around their centre.

If I just did RTFM I'd have known. Even displaying the grid lines is easy. But I thought Word is supposed to be 'easy to learn without RTFM', and if I would have designed it, I would have turned the grid 'off' by default.

Anyway, one problem solved. Maybe the others - except Word crashing from time to time - can be solved too. Sadly, sometimes the MS Word help is a PITA to find what you're looking for. And sadly I'm now investing my time in learning MS Word...

Posting in this forum is limited to members of the group: [ForumMods, SITEADMINS, MEMBERS.]

Becoming a member of LXer is easy and free. Join Us!