Nvidia kernel driver versions

Forum: LXer Meta ForumTotal Replies: 11
Author Content

Jul 26, 2010
9:33 PM EDT
I have the Nvidia driver dated May 7, version 195.36.24

Just wrested the latest driver from Nvidia.com, version 256.35

That seems like a huge leap to me. Did i grab the wrong driver or something? The GeForce [Go] 6150 is listed as supported with 256.35, but I'm paranoid.

Anyone doing the newest?

If I run their new installer, and want to go back, do you think it will work?

Jul 26, 2010
9:38 PM EDT
Yes, you got the right file. Supposed the driver file you download is named "nvidia.run" and you want to uninstall it. You would would just stop gdm (or kdm) service, then do: sudo sh nvidia.run --uninstall

I got an error trying to compile it, saying it doesn't work with my distro or something, so I'm sticking with 195 until the new one show up in the repository.

As a side note, be careful when you upgrade NVidia cards, you might be getting the same thing: http://s20.photobucket.com/albums/b233/eksasol/nvidiarebrand...

Jul 26, 2010
10:14 PM EDT
There are distros that still make you shutdown X to rebuild nvidia ... good grief, get out of the stone ages already.

Jul 27, 2010
12:27 AM EDT
Actually, the Nvidia installer doesn't want X to be running during the build. Or at least it didn't as of version 195.

Jul 27, 2010
7:20 AM EDT
I just upgraded my work machine to Slackware 13.1. I used the slackbuilds.org slackbuild with 195.36.15, and did not have to shut off X, yet it works just fine.

Jul 27, 2010
11:14 AM EDT
Glad to know that --uninstall is working. I'm also not quite newbie enough to delete the old one before knowing that the new one is working. :^)

I'll try it and let y'all know.

Jul 27, 2010
12:24 PM EDT
@gus3 I have been building the module for several years without. Without a warning about it either. I do seem to remember having to do so in Debian before I walked away from them some years ago. That was the last time I had to though.

Jul 27, 2010
5:54 PM EDT
Quoting:@gus3 I have been building the module for several years

So have you finished it yet?

Jul 27, 2010
7:07 PM EDT

Jul 28, 2010
2:53 PM EDT
Quoting:There are distros that still make you shutdown X to rebuild nvidia ... good grief, get out of the stone ages already.

I encountered this with Gentoo last month (or so), as I had to manually 'modprobe -r' the running nvidia module. Otherwise X wouldn't boot.

OK, literally I didn't have to restart X as long as the old kernel was running (while the new one already had been installed), but next time X tried to boot (without me rebooting the computer), it didn't work. Had I just taken the Windows approach and rebooted the whole system instead of just X, this wouldn't have been a problem.

First time in 'bout 7 years I encountered this problem though, weird!

But then, Az is right, because after all Gentoo is from the stone ages. It's even older than Ubuntu, could you believe that - some Linux existing before Ubuntu?

Jul 28, 2010
6:03 PM EDT
I tried building the Nvidia module this morning, with X running (runlevel 4, Slackware-current), and it did complain about having X running. I copied the error message into a file, which I can't get to at the moment because I'm not home.

Jul 28, 2010
9:30 PM EDT
Here's the error text:

Quoting:ERROR: You appear to be running an X server; please exit X before installing. For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the Linux driver download page at [url=http://www.nvidia.com.
]http://www.nvidia.com.[/quote][/url] And then it goes to the "build failed" message, followed by program exit.

Program version: NVIDIA Linux x86_64 256.35

Posting in this forum is limited to members of the group: [Editors, MEMBERS, SITEADMINS.]

Becoming a member of LXer is easy and free. Join Us!