Weird behaviour colors reversed, don't know why

Forum: LXer Meta ForumTotal Replies: 6
Author Content

Aug 12, 2012
10:53 PM EDT
I was working on my Ubuntu (Luxid) box, when suddenly the colour scheme reversed without warning (I have no idea why, but I suspect I inadvertently triggered some keyboard short-cut). Every item on my display -- except the wallpaper and the desktop icons, were shown in reversed color scheme. When I fired up Firefox, this applied to the browser Window as well -- text was white on black, yellow was blue, etc.

I would have thought it was potentially useful, if I could figure out how to toggle it on and off.

I couldn't find anything listed in the preferences configuration under Apearence or Assistive Technologies, Keyboard or Keyboard Shortcuts, or even Windows.

edit: When I tried to see if there was a relevant Compiz setting, everything went back to normal, so it might be a Compiz setting. But the compiz menu items don't seem to work anymore.

edit: Doogling with various terms finally led me to the answer. It appears that the not well documented answer is

<Super> + m

which is good to know.

Aug 13, 2012
4:01 AM EDT
Just to go completely off-topic.....David Ashley and I were teaching a Comp 101 class last year and we got into keyboard shortcuts. A lady in her 60's suddenly became very agitated and obviously wanted to discuss something. She would every now and then, inadvertently hit (like you did Bernard) an unknown key and her screen would go full screen on her, making her navigation buttons completely disappear. She stated that even upon reboot, the browser returned to that state and she could do nothing with it. She would then completely wipe the drive and reinstall the OS because......

She simply did not know how to toggle full screen on and off with F11. She was both relieved and angry because that little (lack of a )jewel of knowledge had cost her so much time and angst. Amazing.


Aug 13, 2012
8:08 PM EDT
And <Super> + n will do the same for a window (one of my favorite Compiz whiz-bangs). I suspect more than one Compiz keybinding has been left active either by default or by accident!

Aug 13, 2012
8:22 PM EDT
What's happening with Compiz?

I gather that it's fallen into something of a Limbo -- which seems rather a shame.

Aug 13, 2012
9:34 PM EDT

I can certainly understand how someone would end up doing that -- though if I found myself doing that repeatedly, I would certainly try to google for an explanation...



Thanks! That's actually more useful to me.

Aug 14, 2012
9:59 AM EDT
Compiz isn't quite in limbo yet, but I'm worried that it might be teetering on the brink. The last forum posts were back in September, the current version is 0.9.8 (SO close!) and Sam Spilsbury wrote on July 5:

"Since last year at the Product Strategy group at Canonical, we have shifted our focus to quality, testing and best practices development."

Planet Compiz maintains current updates, but there's not a whole lot of new information.

Aug 30, 2012
12:21 PM EDT
Intermediate Update [and serious too]

Overall I like Mint 13 better than Mint 10 despite some oddities.

Partial correction, what is called Suspend (or what we see as Sleep) mode works seemingly without fail. The only instance where it did not behave properly was once when I left it in screen saver mode for quite a period, closing the laptop lid did not seem to put it into Sleep mode. In all other instances I have been able to enter and to exit Sleep mode without problems.

The Hibernate mode, I think, worked (at least) once under Mint 13. My memory that under Mint 10 it mostly worked, but was unreliable. For me, that is no problem, since I prefer to shut down fully prior to traveling with my machine or when leaving it behind for several hours.

Odd things I have observed were it reseting of preferences by an unknown cause that was a short term pain to rectify. And more recently seeing an apparently anomalous shutdown mode where the base desktop screen remains until a full power off that follows hitting the confirm button. The usual pattern after hitting the button is to go to the blank, darkened screen where a few text lines show actions towards final shutdown. In the case of the former, upon restarting the machine asks for user id, then password then seems normal until repeating the process of inputting the id and password to regain access. The short period between these login cycles I have control of the machine only to lose it without warning.

I have now seen this twice and seeing the desktop screen remain instead of the darkened screen seems to be the key element. I wondered if this might be linked to my lower wireless bandwidth, by being two virtual connections to the router. So far I have not confirmed multiple logins. The who command sees only my id on two terminals, the base and on tty1 for the running Mint for exactly the same time. My reason for this check was on the first login I saw the highest bandwidth to date under Mint 13, i.e. 80%. It dropped into the lower seventies after the second login. I will be checking to see if I might get a more detailed picture from the wireless router, also checking another possibility that someone or an external device is taping into my connection despite having a very long, random pass phrase.

One reason I prefer Mint 13 is the easy access to multiple desktops just with the motion of the mouse. Moreover, I had one maddening gripe against 10, when the screen hinted it was headed into screen saver mode no amount of mouse motion or key hits would stop it. Under 13 I rarely have that problem.

I like the Mint 13's menu and Cinnamon is not bad at all.

More later, [/serious]


Posting in this forum is limited to members of the group: [Editors, MEMBERS, SITEADMINS.]

Becoming a member of LXer is easy and free. Join Us!