RPi 3 -- available already

Story: Raspberry Pi 3 ReleasedTotal Replies: 33
Author Content

Feb 29, 2016
11:15 AM EDT
Wow, just minutes after the announcement of the RPi 3, I checked on Amazon and found it already in inventory. Since I'm using RPis all over the place for a variety of control tasks, it was only logical that I would get one of the new units to check it out. Mine should arrive on tomorrow's delivery truck. How fun!

Unfortunately, it is now confirmed that the RPi 3 will not support 2160p/4K resolution over its hdmi port, only 1080p. This puts it a step behind the Pine64, although the Pine64 is still a few months out, so there is the bird-in-the-hand factor favoring the RPi 3.

Feb 29, 2016
2:24 PM EDT
> Unfortunately, it is now confirmed that the RPi 3 will not support 2160p/4K resolution over its hdmi port, only 1080p. This puts it a step behind the Pine64, although the Pine64 is still a few months out, so there is the bird-in-the-hand factor favoring the RPi 3.

Agreed. The Pine 64 also has a 2GB version. 1GB is too tight for average web browsing these days. All x86 systems I build get a minimum 4GB currently, simply to have enough overhead for multitasking.

Feb 29, 2016
4:50 PM EDT
Raspberry Pis just aren't in the class of anything but a hobby/special interest machine (i.e.: make-shift file or print server). It's getting closer all the time, but they're still pretty far from anything you'd want to use on a daily basis for normal computing tasks. I had some plans for what I might want to do with my Pi 2, but after playing with it,... It's just not suited for most of them.

Feb 29, 2016
8:17 PM EDT
JaseP: I agree that the RPi is not an attractive desktop replacement. What it is is a very economical and flexible embedded system.

If you wanted to automate your HVAC system, control your lawn watering, or do remote security cam monitoring/archiving, you wouldn't deploy a big desktop system to those tasks. That's the role that the RPi fits very well. I've been using them like cookie-cutters for small tasks like that. When my RPi 3 shows up on the UPS truck tomorrow, it will make number 15, all of which are deployed doing their dedicated functions. All are linked over secure ssh connections for monitoring and control.

Two things that make the RPi very valuable for embedded tasks: a big 40 pin I/O connector ready to interface to your world, and Linux with all the flexibility that Linux brings.

But JaseP, I agree with you on this point: If you are looking for a desktop machine then the RPi is not it.

Mar 01, 2016
12:32 AM EDT
I guess it comes down to what one mean by "desktop".

It if is some kind of graphics workstation, yeah it will come up short.

But as a web terminal/media player i think the only limitation is the reliance on USB for connecting storage.

Mar 01, 2016
12:42 AM EDT
Until the Pi has hardware accelerated OpenGL for the desktop (non-experimental) it won't be ready to be a prime-time media player either (video at least).

Mar 01, 2016
1:14 AM EDT
Hogwash. Been playing video without that for years.

Mar 01, 2016
9:00 AM EDT
I've been using an RPi2 as my media center for a year now and it works fine using the hardware-accelerated omxplayer. I've attached an 8TB external drive to complete the package. Video playback is perfectly free of artifact and the playback is full speed with no missed frames.

My only complaint is that I can't upgrade my system to 2160p/4K with it. The RPi's GPU is limited to 1080p. I'm on schedule to receive a Pine64 soon and I'm hoping that it will be suitable as a 4K media center.

Mar 01, 2016
10:43 AM EDT
My understanding is that omxplayer and the several versions of Kodi that run stand alone is that they run OpenGLES rather than OpenGL,... meaning no switching between a more standard desktop and a media center app. In my attempts to get something like VLC to run, the color is washed out and the playback suffers if trying to switch between windowed and full screen modes, especially if I adjust the cropping (avoiding black bars on the sides for 4:3 video).

I read a whole thing about tweaking the Pi 2 for use with OpenElec,... and several of the tweaks are a no-go for me,... Like switching the network support from SMB to NFS...

So, you may have been able to get it to work for you,... But with the various compromises, it's still a no-go for me...

Mar 01, 2016
10:49 AM EDT
>Video playback is perfectly free of artifact and the playback is full speed with no missed frames.

I've tried the RPi for video playback. The only way I can get 1080p videos to play at all is to decrease the quality of the video. All the high quality videos either don't play at all or stutter and drop frames every 0.5 sec...

I was curious so I tried to play a particular clip which I use as a test case. The clip is 1080p and has a high number of items in constant motion.

Here's the info:

Input #0, matroska,webm, from 'hq_clip.mkv':
    ENCODER         : Lavf57.25.100
  Duration: 00:00:29.49, start: 0.000000, bitrate: 30764 kb/s

[6fe084e0] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)

pi@raspberrypi:~ $ uname -a Linux raspberrypi 4.1.17-v7+ #838 SMP Tue Feb 9 13:15:09 GMT 2016 armv7l GNU/Linux

pi@raspberrypi:~ $ free -h total used free shared buffers cached Mem: 925M 780M 145M 17M 50M 599M -/+ buffers/cache: 130M 795M Swap: 99M 0B 99M

pi@raspberrypi:~ $ lscpu Architecture: armv7l Byte Order: Little Endian CPU(s): 4 On-line CPU(s) list: 0-3 Thread(s) per core: 1 Core(s) per socket: 4 Socket(s): 1 Model name: ARMv7 Processor rev 5 (v7l) CPU max MHz: 900.0000 CPU min MHz: 600.0000

So, my question is:

Which codecs are you using to enable full speed, no dropped frames, high quality 1080p video on the RPi?

I can't find an acceptable mix of codecs... and I've tried a lot of variations.

However, I have zero problems running the Pi as a media server --- just not as a direct render device.

Mar 01, 2016
11:56 AM EDT
If you want true 4k hdmi in a rpi format today, you could look at the $40 Odroid C2. I've not had opportunity to play with these, but they are faster than the rpi3 and support UDH/4K@60Hz. However, no WIFI.

Mar 01, 2016
2:01 PM EDT
Several questions there, and I'll try to answer them one by one:

First, the video player, omxplayer, is hardware-accelerated, but the desktop X11 is not hardware-accelerated, so attempting to play video through an arbitrary desktop app like VLC will be disappointing on the RPi. I've set up the file manager so that all video files play in omxplayer, that way any video I click on will play hardware-accelerated.

Here is a sample of the stats gathered by omxplayer running on an RPi2 with a test video file I have. Notice that the codec is "omx-h264":

$ omxplayer --stats  test_1080p.mp4
Video codec omx-h264 width 1920 height 1080 profile 77 fps 25.000000
Audio codec aac channels 2 samplerate 44100 bitspersample 16
Subtitle count: 0, state: off, index: 1, delay: 0
V:PortSettingsChanged: 1920x1080@25.00 interlace:0 deinterlace:0 anaglyph:0 par:1.00 layer:0                   
M:272371276 V: -0.06s      0k/  4800k A:  0.07  -0.23s/  6.34s Cv:     0k Ca:     0k 

A 720p test video looks like this:

$ omxplayer --stats test_720p.mkv
Video codec omx-h264 width 1280 height 720 profile 100 fps 29.970030
Audio codec ac3 channels 6 samplerate 48000 bitspersample 16
Subtitle count: 0, state: off, index: 1, delay: 0
V:PortSettingsChanged: 1280x720@29.97 interlace:0 deinterlace:0 anaglyph:0 par:1.00 layer:0                    
M:96779115 V:  5.29s   4800k/  4800k A:  3.12   3.09s/  4.02s Cv: 10238k Ca:  2529k   

Both tests play at full rate with no artifacts.

NoDough: Thanks for the tip on the Odroid C2. I had looked at that a while back but did not realize that it had been released. I went ahead and put one on order, it looks perfect for what I'm wanting to do with 4K media even with support for 60Hz over HDMI 2.0, perfect. Lack of wifi is not an issue for me since my media center is ethernet connected, so the Gigabit NIC on the C2 is really a big plus point for me. I'm not sure about the software stability or maturity, but I'll get a better handle on that once mine comes in. (current status: pre-orders are accepted today with shipments on March 4). I'll drop some notes on LXer after I get some results and first impressions.


Mar 01, 2016
3:00 PM EDT


My test clip works perfectly using omxplayer.

It wasn't clear to me from your prior post that omxplayer is RPi specific and built using a Broadcom specific library for audio/video processing.

Now it all makes sense... omxplayer is directly accessing the video memory.

In fact, running the X server is unnecessary overhead... and videos play just fine - with lower processor usage - if I shut down the X server and play the video from a text only login.

Again... Excellent!


Mar 01, 2016
5:02 PM EDT
Running OpenElec on mine and I've never looked back.

Mar 01, 2016
7:42 PM EDT

just did...

I agree. OpenElec is the way to go for a media center. It connects to my DLNA server and is much faster than my 'smart TV.' I suppose now, every TV will be a smart TV with a $35 RPi box.

No more hidden ad networks or weird open ports.

Mar 01, 2016
7:56 PM EDT
> No more hidden ad networks or weird open ports.

Exactly. I spend a lot of time protecting my right to privacy, and it was very refreshing finally moving away from proprietary media solutions over to a FOSS solution. No more wasted time with Wireshark trying to determine which apps were not calling home so that I could safely open my firewall to them.

To me a "smart TV" is not an marketing advantage. A vendor controlled closed proprietary smart TV is a liability, it just means more work for me before I could deploy and use it.

Firewall your TV and replace the "smarts" with an RPi (or an Odroid-C2).

Mar 01, 2016
8:13 PM EDT
UPS truck arrived !


Mar 02, 2016
12:20 AM EDT
@OpenElec for RPi....

I don't like systems that have an unchangeable default root password.

I guess I'm going to have to "unsquash" the thing like this:


Mar 02, 2016
11:40 AM EDT
I found the original Pi to be useful with Kodi on it, but when using WiFi it would often choke on 1080p video. Since I upgraded the unit in the living room to a Pi 2, I haven't had any issues with 1080p video. I admit that I use NFS on my file server to make the network faster, though I'm not sure this is really necessary anymore with the Pi 2. OSMC is my current favorite pure Kodi system for use on the Pi 2.

For video on a Pi in desktop mode (or from the command line) I've always used omxplayer.

I'm not really concerned with 2160p video. To me, it doesn't seem worth the file size and bandwidth it uses. Some of my Blu-Rays are ripped to 720p just because it takes up less space. I still have more movies at 480p than at higher resolutions, and I don't really feel deprived when I watch them (of course, quite a number of them don't have a release at higher resolution).

Mar 02, 2016
12:25 PM EDT
RPi3 -- first impressions:

- Just unplugging an sdcard from a working RPi2 doesn't bring up an RPi3. A download of the current Raspbian and a fresh dd to an sdcard was what it took to bring it up.

- The on-board Wifi came right up with a WPA2 login screen and the association was quick with no fuss, however, dhcp was not invoked correctly and an incorrect IP address was assigned to the wlan0 interface. I had to configure IPV4 settings manually in order to place it in the local network. This was not really a big deal and I'm sure this will be quickly worked out, but it is likely to cause some beginners some trouble getting started.

Other than those two points, the RPi3 is performing as expected.

Mar 02, 2016
12:47 PM EDT
>an incorrect IP address was assigned to the wlan0 interface

I'm not asking you to post the errant IP address... However, I'm very curious as to how the address was 'incorrect'.

What do you mean by incorrect?
  1. Wrong address pool within the correct DHCP network.
  2. Wrong Class A net.
  3. Wrong Class C net.
  1. vs.
  2. vs.
  3. vs.
I've had some strange DHCP assignments of my own before I disabled my ISP's router's DHCP and implemented my own DHCP server and registered it as 'authoritative' ... I seem to remember even getting a DHCP assignment from openDNS or something... So, depending on the kind of 'incorrect' DHCP address, you may want to look a bit deeper into the various DHCP servers and how they are all interacting.

Mar 02, 2016
1:18 PM EDT
>an incorrect IP address was assigned to the wlan0 interface

The initial address assignment after wifi association was 
with a gateway assignment of:
My subnet here is a class C in 192.168...

There are six RPis (RPi1 and RPi2 models, all running Raspbian Wheezy) on this wlan all of which are successfully fetching a dhcp assignment on bootup, so there is some sort of weirdness going on with the RPi3 or more likely with the Raspbian Jessie (Feb 29, 2016) software configuration.

I didn't spend a lot time on this issue since it was easy to manually configure the settings and then just move on.

Mar 02, 2016
2:25 PM EDT
> with a gateway assignment of:

That's a default IP when it can't get a dhcp address. So yes, there's something strange going on.

Mar 02, 2016
3:09 PM EDT

This is the 'link-local' address range:


I've seen this pop up on my network when I was figuring out how to disable the ISP dhcp server on the LAN side... my guess is there is some sort of contention between the ISP router and perhaps your own internal wireless router DHCP. If that's the way you have it setup..

Mar 02, 2016
8:33 PM EDT
It's quite possible that this problem is due to marginal signal quality on the wifi.

I've noticed that the on-board wifi antenna needs to be oriented just right, otherwise we get some packet loss. We could go on the theory that we had packet loss during the dhcp handshake which resulted in the failed IP assignment. In this case the wifi box is located on the other end of the house from the RPi3 although some of the other RPis on this network are solid with their usb wifi adapters.


Mar 02, 2016
11:20 PM EDT

that's an interesting thought.

I bet you could test that using the iw utilities on the client [RPi] and looking through the DHCP and other logs on the router...


It wouldn't be surprising to find out that the RPi 3 wifi has a signal problem versus the USB dongles. Is there an antenna connection on the board? I haven't looked through the RPi 3 docs yet...

Mar 12, 2016
7:37 AM EDT
nodough: You suggested I check out the $40 odroid-c2 for my media center upgrade. After looking at the specs I put in an order and mine came in yesterday.

First impressions:

- The download of a 1.2GB Ubuntu image for this device took about 6 hours to complete. The servers are evidently being hit pretty hard right now.

- Odroid-c2 supports 4K/2160p at 60Hz. I don't have a 60Hz monitor, but I was able to verify it on my 4K 30 Hz monitor and it worked fine, no complaints. The hardware accelerated driver is not yet complete, so the screen is currently being updated with software (too slow for movies) but the driver is being actively worked and I'm looking forward to testing it when it comes out. The performance right now is fine for desktop use but we'll need the hardware acceleration before we have a viable media box solution.

- Ethernet at 1 Gbps was a joy to use. Transferring big files from my media storage server over to this device runs really fast. I'm thinking that this network performance will permit playing videos directly over an nfs connection without use of a local disk.

- This device supports both an sdcard and an emmc card. I'm using the sdcard right now and the speeds are quite comfortable, however the vendor claims 120MB/s speeds when running on an emmc card. That would be incredible. I just may order an emmc card so that I can check this out.

- There are some minor software stability issues, like Firefox crashes (Chromium is stable), but the vendor seems to be active in working the issues as fast as they can.

All in all, I think the odroid-c2 will be a device to watch over the weeks ahead. The specs on this device are ahead of the pack, and the developers seem to be on the right track with the software.

(This post was written using an Odroid-c2 running Ubuntu64 16.04lts-mate with the Chromium browser.)

Mar 14, 2016
9:05 AM EDT
penguinist: Thanks for the update. I've been holding off ordering more Pi. Now I'm thinking the Odroid-c2 is more to my liking.

Mar 14, 2016
9:16 AM EDT
Since my last post, a hardware accelerated kodi (alpha) has been released for the c2. I'm checking it out now and there are issues with it not handshaking correctly with a 4k monitor, so it's not ready for prime-time yet, but it's encouraging to see the work progressing rapidly.

Mar 16, 2016
8:47 AM EDT
penguinist: Normally, I wouldn't post a link to an online sale, but I think this is germane to the discussion.

One of today's NewEgg ShellShockers is a 4K UHD 28" LED 3840x2160 60Hz monitor for $279. Of course, it's a brand I've never heard of, but if you're looking for a 60Hz 4K display, now might be a good opportunity.


My apologies to the moderators for posting a sale link.


P.S.: To add a little humor, here's a line from the manufacturer: "4K UHD resolution has over than 800M pixel, so it is shown the objects close to real."

Mar 16, 2016
9:56 AM EDT

That is indeed interesting. The claim is that this is a 4K monitor with support for 60Hz, and the price is right. But on a closer read of the specs we see that this monitor supports hdmi 1.4a which limits performance over hdmi to 30Hz frame rates. The odroid-c2 supports hdmi 2.0 which is what we need to get true 60Hz updates. I notice also that this monitor supports DisplayPort 1.2a, and it is with DisplayPort that it reaches its 60Hz potential. But the odroid-c2 does not support DisplayPort so that would be a disconnect for us. So I'm still hunting for my hdmi2.0 / 4k / 60Hz display upgrade.

On another topic, I've been closely following the software side of the odroid-c2 and there continues to be some good work in the direction of harnessing the mali-450 hardware accelerated gpu. Right now there is a hardware accelerated framebuffer driver and there is active work to run the kodi media app on it. I've tested it and have found that it will drive 4k/30Hz (sorry I don't have a 4k/60Hz display yet) with acceleration, however there are still issues with the kodi integration, so odroid-c2 is very close to supporting 2160p/60Hz in a media center application but it's not quite there yet.

Mar 16, 2016
2:11 PM EDT
penguinist: Good catch. The devil is in the details.

Mar 20, 2016
11:00 AM EDT
Odroid-C2 update:

I've been testing the 4K hardware accelerated Kodi (formerly xbmc) on the C2, and it is starting to look pretty good. The C2 can now play 4K video with reasonably good quality. The C2 supports 60Hz but my monitor is limited to 30Hz so I can't test it at full speed, that will need to wait for a monitor upgrade. The video shows no sign of tearing or other anomalies, and is basically "watchable" right now.

The only issue I can see is that I'm getting some minor jerkiness on fast moving scenes (unnoticable on slower moving scenes). It's quite possible that the cause of this is not the C2's GPU/driver but the bandwidth limitation of the sdcard I'm using to store the video file. I have an emmc card on order which should give me a way to eliminate storage bandwidth as the cause.

All in all, I'm pretty pleased with what we have. It's time to start looking for a large screen 2160p@60Hz hdmi 2.0 tv for my next entertainment center upgrade.

On the downside, this Kodi implementation is based on fbdev framebuffer display, so we can't run a full desktop accelerated yet. That part is still in the works, but if you are happy with a dedicated Kodi system, that part seems to be in our hands.

Mar 20, 2016
11:59 AM EDT
penguinist - I'm really enjoying reading your updates, as you experiment with the Odroid-C2. Thanks for sharing your findings with us. Good Stuff!

Posting in this forum is limited to members of the group: [ForumMods, SITEADMINS, MEMBERS.]

Becoming a member of LXer is easy and free. Join Us!