Anyone still using Firefox? I have a new problem upgrading

Story: Web Input - Securing Data, Hybrid ApproachTotal Replies: 2
Author Content
TxtEdMacs

Jan 12, 2022
10:34 AM EST
Mozilla ceased delivering a compressed package to my ./Downloads directory ages ago.

Even earlier Firefox in my home directory stopped updating automatically. As a result I have a kludge where the new compressed firefox is decompressed from the version in ./Downloads and transferred as an over write into the /opt directory. And it worked until Mozilla stopped going into the ./Downloads.

However, it had a graphic showing the decompression. Moreover when clicked on it showed a directory approximately like this: /tmp/(myname)0/firefox-##.0.n.tar.bz2. Then selecting properties I just put the mouse cursor on the file and selected Copy, which I then pasted into my ./Downloads file and ran the kludge to have a fully functional, updated version of Firefox.

Currently I am on the 95.0.2 version running and attempting to download the new version fails. What differs is the download function appears along the Firefox address bar. And multiple times it claims Firefox was successfully transferred. However the graphic mentioned above is absent. Furthermore when I attempt to copy over from this list I get this error message (details):

“/tmp/mozilla_(myname)0/firefox-96.0.tar-13.bz2”: No such file or directory

I also checked the /tmp directory independently and nothing near to the naming is present.

It appears to me that they have added so many features they neglected the function. As you see this was my 13th attempt. And I do no better with their link, which just claims to be the location of the file on the Mozilla site.

So has anyone else encountered similar problems and if so is there a solution ... other than Brave?

Thanks for reading this far!
TxtEdMacs

Jan 12, 2022
8:44 PM EST
Solved:

Went to Mozilla site on the Chrome browser and requested the same upgrade, it worked landing in my ./Downloads directory. The only slight problem was seeing the older version initially, but soon a message appeared saying a restart of the browser was necessary. The next check confirmed I had 96.0.
jdixon

Jan 13, 2022
11:30 AM EST
I only get Firefox updates via the Slackware update process, so I've never had the problem.

Of course I only use Firefox as a last resort at this point. Palemoon, Otter, and Brave are all better or as good.

Posting in this forum is limited to members of the group: [ForumMods, SITEADMINS, MEMBERS.]

Becoming a member of LXer is easy and free. Join Us!