Red Hat alert: Updated KDE packages fix security issues

Posted by dave on Sep 16, 2003 12:45 PM EDT
Mailing list
Mail this story
Print this story

Updated KDE packages that resolve a local security issue with KDM PAM support and weak session cookie generation are now available.

Hash: SHA1

- ---------------------------------------------------------------------
                   Red Hat Security Advisory

Synopsis:          Updated KDE packages fix security issues
Advisory ID:       RHSA-2003:269-01
Issue date:        2003-09-16
Updated on:        2003-09-16
Product:           Red Hat Linux
Keywords:          PAM pam_krb5 pam_setcred
Cross references:  
Obsoletes:         RHSA-2003:235
CVE Names:         CAN-2003-0690 CAN-2003-0692
- ---------------------------------------------------------------------

1. Topic:

Updated KDE packages that resolve a local security issue with KDM PAM
support and weak session cookie generation are now available.

2. Relevant releases/architectures:

Red Hat Linux 7.1 - i386
Red Hat Linux 7.2 - i386, ia64
Red Hat Linux 7.3 - i386
Red Hat Linux 8.0 - i386
Red Hat Linux 9 - i386

3. Problem description:

KDE is a graphical desktop environment for the X Window System.  

KDE between versions 2.2.0 and 3.1.3 inclusive contain a bug in the KDE
Display Manager (KDM) when checking the result of a pam_setcred() call. 
If an error condition is triggered by the installed PAM modules, KDM might
grant local root access to any user with valid login credentials.

It has been reported that one way to trigger this bug is by having a
certain configuration of the MIT pam_krb5 module that leaves a session
alive and gives root access to a regular user.  The Common Vulnerabilities
and Exposures project ( has assigned the name CAN-2003-0690
to this issue.

In addition, the session cookie generation algorithm used by KDM was
considered too weak to supply a full 128 bits of entropy.  This could make
it possible for non-authorized users, who are able to bypass any host
restrictions, to brute-force the session cookie and gain acess to the
current session.  The Common Vulnerabilities and Exposures project
( has assigned the name CAN-2003-0692 to this issue.

Users of KDE are advised to upgrade to these erratum packages, which
contain security patches correcting these issues.

Red Hat would like to thank the KDE team for notifying us of this issue and
providing the security patches.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which are
not installed but included in the list will not be updated.  Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network.  Many
people find this an easier way to apply updates.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:


This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

If up2date fails to connect to Red Hat Network due to SSL Certificate 
Errors, you need to install a version of the up2date client with an updated 
certificate.  The latest version of up2date is available from the Red Hat 
FTP site and may also be downloaded directly from the RHN website:

5. RPMs required:

Red Hat Linux 7.1:



Red Hat Linux 7.2:




Red Hat Linux 7.3:



Red Hat Linux 8.0:



Red Hat Linux 9:



6. Verification:

MD5 sum                          Package Name
- --------------------------------------------------------------------------
cb6bb0a57fe9f3b14a20587f46987d4f 7.1/en/os/SRPMS/kdebase-2.2.2-0.71.5.src.rpm
5a46ecc2211a258c40bf507b8b29abd3 7.1/en/os/i386/kdebase-2.2.2-0.71.5.i386.rpm
40b6300799af3d9bc02e7e22a7379497 7.1/en/os/i386/kdebase-devel-2.2.2-0.71.5.i386.rpm
920975f4a5a0ad3afed469b4cd7101bc 7.2/en/os/SRPMS/kdebase-2.2.2-11.src.rpm
80e0d4d9a3d43578db0acc7ff8df220d 7.2/en/os/i386/kdebase-2.2.2-11.i386.rpm
c7dc480e86ba296ea49405957a099e98 7.2/en/os/i386/kdebase-devel-2.2.2-11.i386.rpm
299579139bcce74c6a7016b541345b4c 7.2/en/os/ia64/kdebase-2.2.2-11.ia64.rpm
78c1159be0e74352400a05ad3e01ae90 7.2/en/os/ia64/kdebase-devel-2.2.2-11.ia64.rpm
c447ab78bdbc8543efbb808a43729385 7.3/en/os/SRPMS/kdebase-3.0.5a-0.73.4.src.rpm
b065e5b78dd710934b63f328b08d1560 7.3/en/os/i386/kdebase-3.0.5a-0.73.4.i386.rpm
ae98720219e096dfa1793b95de7f4ebc 7.3/en/os/i386/kdebase-devel-3.0.5a-0.73.4.i386.rpm
15ecc4af762e759f88ecf568711a68df 8.0/en/os/SRPMS/kdebase-3.0.5a-9.src.rpm
5b6bd4dbb3dcd08bfbd091cf6fdada0d 8.0/en/os/i386/kdebase-3.0.5a-9.i386.rpm
c703a3356091161e3147ffdbccf9763b 8.0/en/os/i386/kdebase-devel-3.0.5a-9.i386.rpm
549903de2f482c68f05cb0659a085560 9/en/os/SRPMS/kdebase-3.1-15.src.rpm
4bb6fef4d5f0a82473082912926daeda 9/en/os/i386/kdebase-3.1-15.i386.rpm
d2ba495ab6fea5d3ef67e96cfca32d59 9/en/os/i386/kdebase-devel-3.1-15.i386.rpm

These packages are GPG signed by Red Hat for security.  Our key is
available from

You can verify each package with the following command:
    rpm --checksig -v 

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the md5sum with the following command:

7. References:

8. Contact:

The Red Hat security contact is .  More contact
details at

Copyright 2003 Red Hat, Inc.
Version: GnuPG v1.0.7 (GNU/Linux)


» Read more about: Story Type: Security; Groups: Red Hat

« Return to the newswire homepage

This topic does not have any threads posted yet!

You cannot post until you login.