Debian alert: New ht://Check packages fix cross site scripting problem

Posted by dave on Oct 8, 2002 11:58 AM EDT
Mailing list
Mail this story
Print this story

Package : htcheck Vulnerability : cross site scripting Problem-Type : remote Debian-specific: no

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 169-1                                        Martin Schulze
September 25th, 2002          
- --------------------------------------------------------------------------

[ Resent since this advisory did not appear in the list archive.
Also, this is the real DSA 169-1. ]

Package        : htcheck
Vulnerability  : cross site scripting
Problem-Type   : remote
Debian-specific: no

Ulf Harnhammer discovered a problem in ht://Check's PHP interface.
The PHP interface displays information unchecked which was gathered
from crawled external web servers.  This could lead into a cross site
scripting attack if somebody has control over the server responses of
a remote web server which is crawled by ht://Check.

This problem has been fixed in version 1.1-1.1 for the current stable
distribution (woody) and in version 1.1-1.2 for the unstable release
(sid).  The old stable release (potato) does not contain the htcheck

We recommend that you upgrade your htcheck package immediately.

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:
      Size/MD5 checksum:      613 d21f5fbf771b87840340810783019bb4
      Size/MD5 checksum:    26394 191d7a90427dd27799ef1b8e71ade0a8
      Size/MD5 checksum:   621515 53cd633f11cc38671d17d4dc68cbe926

  Architecture independent components:
      Size/MD5 checksum:    42150 8714bfe5188922baf0026d1d09eaf657

  Alpha architecture:
      Size/MD5 checksum:   332958 f65daba68e7874161f111b7c875cf32e

  ARM architecture:
      Size/MD5 checksum:   306162 a6f99ed393a6618e972cc2c2e9b538e2

  Intel IA-32 architecture:
      Size/MD5 checksum:   299164 d5116655ecba8997e38e75578bd090bf

  Intel IA-64 architecture:
      Size/MD5 checksum:   345016 6f3c0c708ebbab80a2d62d8c2fe8d6ee

  HP Precision architecture:
      Size/MD5 checksum:   324600 23530dceb3d48d0c7a925edc47ff2e89

  Motorola 680x0 architecture:
      Size/MD5 checksum:   291574 cf88a2efd4e4478561c90a6f371039b7

  Big endian MIPS architecture:
      Size/MD5 checksum:   306856 a0a515062a27d143e462b4a20f7e1545

  Little endian MIPS architecture:
      Size/MD5 checksum:   304234 fd2cd262d9dbdc2d987a9f9690383d02

  PowerPC architecture:
      Size/MD5 checksum:   295642 162e7a347589186e8e8e158c7607a430

  IBM S/390 architecture:
      Size/MD5 checksum:   286584 1075cb5d014b048b10dc4d567563a399

  Sun Sparc architecture:
      Size/MD5 checksum:   291184 e68969c143c341825d26a9a79a943d36

  These files will probably be moved into the stable distribution on
  its next revision.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.0.7 (GNU/Linux)


» Read more about: Story Type: Security; Groups: Debian

« Return to the newswire homepage

This topic does not have any threads posted yet!

You cannot post until you login.