Advanced

Setting up IPv6 on Linux

Posted by SamShazaam on · 7 comments
alphahacker.net
Mail this story
Print this story

IPv6 is the future of IP, and it’s a good time to start learning about it. It’s very easy to put an IPv6 address on Linux. IPv6 addresses have 126 bits. This allows for an enormous address space.

Full Story

  Nav
» Read more about: Story Type: Tutorial; Groups: Linux

» Get new stories by e-mail: nightly or as they are published

« Return to the newswire homepage

Comments (7)

qcimushroom ·
IPv6 addresses are 6 x 8 binary bits 48 bits total.
tuxchick ·
The author is correct- IPv6 addresses are 128 bits long.
vainrveenr ·
IPv4 (version 4) uses
Quoting:32-bit (4-byte) addresses, which limits the address space to 4,294,967,296 (2 to the 32nd power) possible unique addresses.
from http://en.wikipedia.org/wiki/IPv4#Addressing. A typical IPv4 address in dotted-decimal format is 192.168.10.1

IPv6 (version 6) uses 128-bit (16-Byte) addresses. IPv6 thus supports
Quoting:...(about 3.4 × 10 to the 38th power) addresses, or approximately 5 × 10 to the 28th power addresses for each of the roughly 6.5 billion people alive today. In a different perspective, this is 2 to the 52nd power addresses for every star in the known universe – a million times as many addresses per star than IPv4 supported for our single planet.
from http://en.wikipedia.org/wiki/IPv6 A typical IPv6 address in colon-separated hexadecimal format is 2001:0db8:85a3:08d3:1319:8a2e:0370:7334

One can compare in much further detail the specifics of these two IP addressing versions through the Internet Assigned Numbers Authority's (iana's) 'IP Address Services' webpage found at http://www.iana.org/ipaddress/ip-addresses.htm in the section IP ADDRESS ALLOCATIONS

SamShazaam ·
It depends on how you look at it. Using auto-configure mode the last 48 bits is the MAC address. The first 48 bits is the network address. The remaining bits identify type of traffic and priorities, allowing easier firewalls and routing.
tuxchick ·
IPv6 addresses are 128 bits, period. You can't chop off 48-bit chunks to use. Even the shortest form of the loopback address, ::1, is 128 bits. Let's not go all MCSE over this stuff!
dinotrac ·
TC -

> Let's not go all MCSE over this stuff!

I like to think that this is a civilized place. There is no excuse for using that kind of language.
vainrveenr ·
Quoting:Using auto-configure mode the last 48 bits is the MAC address. The first 48 bits is the network address. The remaining bits identify type of traffic and priorities, allowing easier firewalls and routing.
Well taken. These modal address subdivisions are referred to in the more detailed RFC2373 , RFC2462, and RFC3177 guidelines for [arguably] more _effectively_ assigning IPv6 addresses. This within the great, vast IPv6 address space specifically noted above.

RFC2373 is 'IP Version 6 Addressing Architecture', http://www.ietf.org/rfc/rfc2373.txt RFC2462 is 'IPv6 Stateless Address Autoconfiguration', http://www.ietf.org/rfc/rfc2462.txt RFC3177 is 'IAB/IESG Recommendations on IPv6 Address Allocations to Sites', http://www.ietf.org/rfc/rfc3177.txt

Still confused (or are averse to going through all three of these RFCs?)

Then as the IANA 'IPv6 Address Allocation and Assignment Policy' nicely sums this up:
Quoting:8.3. The size of IPv6's address space

Compared to IPv4, IPv6 has a seemingly endless amount of address space. While superficially true, short-sighted and wasteful allocation policies could also result in the adoption of practices that lead to premature exhaustion of the address space.

It should be noted that the 128-bit address space is divided into three logical parts, with the usage of each component managed differently. The rightmost 64 bits, the Interface Identifier [RFC2373], will often be a globally-unique IEEE identifier (e.g., mac address). Although an "inefficient" way to use the Interface Identifier field from the perspective of maximizing the number of addressable nodes, the numbering scheme was explicitly chosen to simplify Stateless Address Autoconfiguration [RFC2462].

The middle 16 bits of an address indicate the subnet ID. Per [RFC 3177, RIRs-on-48s], this field will often be inefficiently utilized, but the operational benefits of a consistent width subnet field were deemed to be outweigh the drawbacks.

The decisions to inefficiently utilize the bits to the right of /48 were made under the knowledge and assumption that the bits to the left of /48 would be managed prudently and that if done so, will be adequate for the expected lifetime of IPv6 [RFC3177].
(from http://www.iana.org/ipaddress/ipv6-allocation-policy-26jun02)

Read the whole comment

Post a comment

A free account is needed to post. Write your comment here first: your text is kept in this browser while you sign up or log in, and is waiting for you when you come back.

Your message:
|||||
10
Markdown: **bold**, *italic*, [text](https://link), - lists, > quotes, $x^2$ for math. Formatting help

Sign up and post (it is free)  or  Log in and post