CD's and DVD's AWOL from system

Forum: LXer Meta ForumTotal Replies: 16
Author Content

Jun 05, 2012
2:15 AM EDT
This is growing into a larger problem for me than I am prepared to handle. We have a few hundred Linux Mint 11 installs "out there" for our HeliOS kids. About a month ago, we began getting calls from kids and parents that their cd-writing software wasn't working because it complained of no blank disk in the drive. The usual pop-up dialog wasn't showing up either.

Lo and behold, it wasn't two weeks later, my Linux Mint 11 production machine started exhibiting the same behavior. I would load a blank cd or dvd (tried all makes and brands) and nada. Sometimes, I would return to my computer an hour or more later and the dialog box for the blank cd would be there. Of course I posted to the Linux Mint forums but it's been ignored and hasn't seen one response or comment.

I am just here to pick your minds and see if you might have any ideas on the matter. The Mint forums have several problems reporting the same issue but they too remain with no response. Here is some command line output and fstab content that might be relevant.

0 dev='/dev/scd0' rwrw-- : 'ATAPI' 'DVD A DH20A4P' 1 dev='/dev/scd1' rwrw-- : 'SONY' 'CD-RW CRX320E'

However, when I check into 'etc/fstab, all I see is:

# /etc/fstab: static file system information. # # Use 'blkid -o value -s UUID' to print the universally unique identifier # for a device; this may be used with UUID= as a more robust way to name # devices that works even if disks are added and removed. See fstab(5). # # <file system> <mount point> <type> <options> <dump> <pass> proc /proc proc nodev,noexec,nosuid 0 0 # / was on /dev/sdb6 during installation UUID=38064524-68e0-4676-8350-302a7006180d / ext4 errors=remount-ro,user_xattr 0 1 # swap was on /dev/sdb7 during installation UUID=c98d15a0-df36-428c-81f7-1b32e9595aad none swap sw 0 0


Jun 05, 2012
4:13 AM EDT
What Cd burning Software?

Jun 05, 2012
4:44 AM EDT
Could this have been something introduced by an update?

Jun 05, 2012
8:28 AM EDT
I've seen the same in both ROSA 2012 Marathon (a Mandriva fork) and in SalixOS 13.37 (a Slackware derivative) so I do not believe it's distro-specific. In the case of ROSA an updated k3b package seems to have fixed the problem. In the case of SalixOS, which uses Brasero in all but the KDE version, the problem is intermittent.

So... while I don't have a specific fix I don't think it's a Mint issue per se.

I'd ask the same questions tracyanne and jacog asked: which burning software are you using? Which version? Was there a recent upgrade?

Jun 05, 2012
8:32 AM EDT
> Could this have been something introduced by an update?

Almost certainly. The question is which one. The most likely bet is a kernel update or the burning software.

Ken, Mint is a Ubuntu derivative, and Ubuntu keeps the old kernels when it does an update (I routinely have to delete them from by 8GB SSD on my Mini 9, or I run out of disk space). There should be a way to boot from the older kernels, though I have no idea what the procedure is with Mint/Ubuntu. I'd try a couple of the older kernels and see if that resolves the problem. If it does, that will help the devs a lot in tracking down the actual issue.

Sep 23, 2012
6:58 AM EDT
As long as this thread has been autorevivified (presumably by a spambot)... What was the resolution of this issue? Was it K3B?

Sep 23, 2012
9:48 AM EDT
Yeah, I clicked on LXer this morning and found a string of Watched Threads running half way down the page, dating back to 2007. Strange indeed.

Sorry for not keeping up with this thread. There are times when I have test appointments that require me to spend two to three days as an inpatient and I get behind in everything.

Caitlyn is correct. This also happened for me in SolusOS and is currently still a problem. I have tried K3b as well during these "outages" and it reports the same problem. Then one day, Bam...I sit down at my computer and there is the CD/DVD dialog, informing me that there is a blank medium in my ROM. It's maddening as I search for the answer and find that the majority of the queries have gone unanswered or the seemingly universal "Change out ur ROM drive n00b" advice is given.

Which incidentally I did, just to cover all the bases. No joy there.

So no, I have not found an answer to this problem and from what I can see via my searches, it spans all distros. One would think that the Greater Minds would tackle this instead of letting it turn into one of the "quirks" of Linux. One would think.

Jan 03, 2013
6:53 PM EDT
Seems to be fixed nowadays. Does anybody know what the issue was?

Jan 04, 2013
4:54 PM EDT
In the case of both SolusOS and Mint, somehow, some way, the privileges for cdrom were changed to root. It certainly wasn't this way on a fresh install. I went in and clicked advanced properties and made sure that I had a check mark next to every device on my computer (which many of them were unchecked) and all worked fine upon reboot. Why a fresh install gave me access to mounted cd's and dvd's and later did not is still a mystery. However changing these properties under users and groups fixed the problem.

When the problem was present, every burner program I tried refused to see the CD/DVD in the ROM. It makes sense now because the actual hardware did not have user privilege.

Jan 04, 2013
5:02 PM EDT
I vaguely remember that. It was a royal pain.

Jan 07, 2013
10:22 AM EDT
The fact that users must be added by hand to groups is annoying, but it's one of those details that must be dealt with. I've gotten caught by it enough to remember every time I add a user or get confounded by some broken service.

It's one of those details that really drives new Linux users crazy.

Jan 07, 2013
12:12 PM EDT
Bob...You know you spend too much time on Google Plus when.....

You look for the +1 marker in other forums.

Jan 07, 2013
12:49 PM EDT

Jan 07, 2013
3:07 PM EDT
(Guessing here because my antique distros don't have this problem) So, for those stuck with this syndrome, a quick hack might be a script, tail-ended onto /etc/rc.local, which blindly forces the proper permissions and ownerships?

Jan 07, 2013
5:52 PM EDT
# addgroup bob floppy # addgroup bob scanner # addgroup bob powerdev # addgroup bob plugdev

etc, etc, etc. I'm sure I've added myself and others to more groups than was strictly needed, but making a habit of going through /etc/group and seeing just what I might have been left off of has made things so very much easier.

Jan 07, 2013
6:05 PM EDT
I do remember having to be in the plugdev group for things to work. I guess I just didn't remember that was the solution.

I used to have a really good memory. Getting old stinks. The alternative is far, far worse.

Jan 09, 2013
9:44 AM EDT
I remember this issue cropping up randomly using Slackware 13 or 13.1 and it was maddening.

Posting in this forum is limited to members of the group: [Editors, MEMBERS, SITEADMINS.]

Becoming a member of LXer is easy and free. Join Us!