VoiP modem problems solved

Forum: LinuxTotal Replies: 3
Author Content

Oct 31, 2013
6:49 PM EDT
This has nothing and yet everything to do with Linux. Nothing, in the sense that Linux does not come into it at all, and everything in the sense that if this problem had NOT been solved, then I would not be on the internet and using my Linux equipment. I offer it here in the hopes that it may help anyone else who might have hit this "feedback loop" problem.

The Situation

Okay, as most readers know, our home runs on a stand-alone solar power system, 240 volts and powered by a Selectronics 3Kw sinewave inverter. Runs beautifully.

Our home is out in the bush so that any phone calls we make are what we call STD or long distance. Quite expensive.

To solve this expense, we invested at last in a VoiP modem and although our first modem was destroyed by lightning last year, it had already saved us about A$2000-3000 in telephone company costs. Paid for itself and then some.

I am also deaf and originally we were running a 240volt powered faxphone which had variable volume and a speaker phone as well as a bedside satellite mobile phone. We no longer needed the fax, but did require the rest of its capability, however that particular phone was getting long in the tooth and needed replacement.

So we replaced the old faxphone with a modern up to the minute Telstra phone which had all the above items and of course, worked on 240volts from our power supplies. No worries.

VoiP Modem Instability

For some time we had noticed instability with the modem. Drop outs, hunting for a suitable setting etc. and were getting very irritated at what was happening. To cut a long story short, the first thing was to ensure that the actual line (copper) we are using was not at fault. You have no idea how difficult it is now to get Telstra to react to a call for help. You also ultimately end up with an off-shore consultant and for a deaf person, this is almost impossible to deal with because of accents. My solution there was to send an email to Telstra, outlining the problems and requesting technical help to check the line. And it was done. The tech arrived, found there was water at the junction and removed it. He then certified the line as being well within all standards and was amazed at just how much speed I was getting on the line. Okay....first problem solved.

But the modem instability remained. It is a Billion Bipac 7401VGP 4-port modem with full VoiP capability. Erratically and at any time of day or night, it would lose the DSL line and then begin to hunt and would go on like that, if left, for hours......

We at first suspected anything.....spurious signals from the inverter, something my son was doing with his gear (sorry Peter, it wasn't you - ever), a defective modem, a filter powerboard playing up......we tried isolating things bit by bit, but the problem remained.

It so happens that before we got our present inverter we had an older one which actually was producing spurious signals on its sinewave output and Selectronics sent us a very nice filter unit (free of charge). It's only about 140watt capability, but it could filter out the power going to our TV set at that time. And suddenly that set could receive digital signals properly. Selectronics did not want the filter unit back and so it has been sitting in the drawer.

On a hunch, I put the filter unit in series with the supply to the new Telstra phone........and bingo. Our modem has been rock solid now for two days and will probably keep on going the same way. Somehow that new telephone produces signals that form a feedback loop through the power lines and upsets the Billion modem and that filter pack totally blocks those spurious signals. Also, looking back on it, it is also likely that previous instability with the earlier faxphone was for the same reason. Powered telephones with VoiP modems have hidden traps and I seem to have uncovered this particular one quite well.......and solved it thank goodness.

There was one last hiccup......I turned the modem on for a final run and got power up, computer connection, DSL line present and a red light for the internet.......it was only after a google check that I found out that in all probability it had lost my user name and password......I checked the appropriate place and it was so.......re-inserted them and all was well.

Another Feedback Loop

This is not the first time I have struck a similar 240 volt feedback loop. A few years back, after I transferred totally to laptop instead of desktop, I still had a desktop hdd which I decided to use as a back up storage device. It was run in the usual 240 volt caddy and worked okay......BUT.......you plugged it all in to the power, waited until the green light appeared and then inserted the usb plug into the laptop which of course, is also running on 240 volts. The moment the plug was inserted, the modem crashed. I confirmed this several times because I just didn't believe it. You could get around it by removing the laptop from the 240 volt supply, but it just wasn't worth the hassle and so now I have the small laptop hdds and the little usb caddies that they require......No problems.

Hope everyone enjoyed the saga........Believe me, it is so nice to see those green lights on the modem all staying steadily where they should be and blinking during data transmission.

Best to all

Ridcully.......aka Tony Young to his friends.

Nov 01, 2013
10:39 AM EDT

The more complex the system, the more such gremlins seem to pop-up with no explanation at all.

Nov 01, 2013
12:50 PM EDT
The more complex the system, the more things there are to break. (As Toyota found out recently, the hard way.)

Addendum: the Toyota system defects are explained here.

Nov 01, 2013
5:23 PM EDT
This is now the third day after insertion of the filter pack.......The modem has not missed a beat. Just sits there and does its job. Feels strange not to be fighting with the thing, but very, very nice. There is an old saying: never throw anything away - you never know when you might need it. That Selectronics filter comes into that category.

You cannot post until you login.