meltdown & spectre

Forum: LinuxTotal Replies: 0
Author Content
kjm007

Jan 23, 2018
12:16 PM EST
As of kernel 4.14.14, you can now check if you are vulnerable to meltdown & spectre, by issuing the following command:

grep . /sys/devices/system/cpu/vulnerabilities/*

my output shows:

/sys/devices/system/cpu/vulnerabilities/meltdown:Mitigation: PTI /sys/devices/system/cpu/vulnerabilities/spectre_v1:Vulnerable /sys/devices/system/cpu/vulnerabilities/spectre_v2:Mitigation: Full generic retpoline

The output shows Meltdown has been patched by PTI (Page Table Isolation), and that my system is still vulnerable to the Spectre variant 1

Spectre variant 2 has been patched with retpoline

You cannot post until you login.