Firefox 4 is unsupported, but don't freak out!

Posted by mcasperson on Jun 26, 2011 9:17 AM EDT
Brighthub; By Matthew Casperson
Mail this story
Print this story

Mozilla recently made headlines by saying (in no uncertain terms) that they would not be providing security fixes for the recently released Firefox version 4. This has caused some concern in the enterprise, who are no doubt aware (thanks to the recent activity of Lulz Security and Anonymous) that security is not something that can be taken lightly. Microsoft also took the opportunity to remind system administrators and CIOs that IE will be supported for many years to come.

Full Story

  Nav
» Read more about: Groups: Mozilla

« Return to the newswire homepage

Subject Topic Starter Replies Views Last Post
Changing browsers in the middle of the (data) stream. helios 8 725 Jun 27, 2011 1:50 PM

You cannot post until you login.