Ubuntu 11.04 beta 2 on my laptop: Unity works

Forum: LinuxTotal Replies: 20
Author Content

Apr 25, 2011
6:45 PM EDT
There has certainly been a lot of improvement in Ubuntu 11.04/Natty since I tried one of the Alphas.

I downloaded the Beta 2 image today and gave it a try on my Lenovo G555 laptop (AMD Athlon II dual-core at 2.1 GHz, AMD/ATI Mobility Radeon 4200 HD video), and now I am in a Unity desktop that is actually working.

I don't exactly know what to make of this new desktop environment, but I can tell you that I don't yet hate it.

If I were to adopt Unity as my DE, I'd definitely need more "buttons" for my favorite applications. It is very Mac like - you search for an application, then launch it, at which time you can right-click to "keep in launcher."

Once you click the little "plus magnifier" icon, you can bring down an application menu from the upper right portion of the screen.

The applications don't have menus on their windows. Instead the menus are on the upper panel -- yep, just like Mac OS X. The app names are longish, and they fade out mostly when you mouse over the upper panel and teh menu appears. That needs a little work - it looks a bit off.

Buttons are still on the left (and there are maximize and minimize buttons). Again, just like OS X.

If you like OS X, you'll like this too. If not, then not.

I can't say it's better, but it sure is different. Desktop wallpaper still looks like purple vomit.

But it's appreciably fast on my hardware. Switching between apps and virtual desktops is smooth.

At this point I'm just happy that it works.

Finding utilities is a pain - you have to search for what you want. I don't see any kind of menu akin to user preferences, but I very well could be missing it. Just bringing up a terminal looks like it requires about five clicks.

However, the system remembers your most-used applications, and they appear at the top of the "search applications" overlay/page.

Sound worked out of the box, but I couldn't get either the internal nor an external microphone to work.

Suspend/resume works.

Unity in Ubuntu 11.04 definitely looks like it's aimed at the decidedly non-technical user. If they can get some preload deals done, I suppose it could work out. At this point there's nothing else quite like this (note: I haven't been able to get GNOME Shell working from a live disc; I will try again in the near future).

Update: I found "system settings" -- under the "power button" icon at the upper right portion of the screen.

Apr 25, 2011
10:26 PM EDT
Quoting:Unity in Ubuntu 11.04 definitely looks like it's aimed at the decidedly non-technical user.

I'm pretty certain most of my "non technical" users will be very confused and want their old desktop back.

Apr 25, 2011
11:44 PM EDT
To sum it up, it borrows heavily from the Mac OS X user interface.

Apr 26, 2011
6:32 AM EDT
Steven: Thanks for explaining the things above.

Have been playing with Natty yesterday.

Certainly not aimed at "existing non-Ubuntu Linux users" it seems, their install page only gives instructions for Windows / Mac / Ubuntu. No "Linux"!

Simply dd'ing the image to USB doesn't work. Installing the bootloader from USB doesn't work either, as the boot loader (grub2) installed itself to SD card instead of HD. Even while I clearly indicated I'm installing to /dev/sda. Both (the dd issue as well) stupid Debian legacy I'm afraid. Other distro's have fixid this for years, but Ubuntu requires UNetBootin or manual CLI-fiddling.

When installed, and after updating to beta2 (Nouveau in 1 didn't work) and installing dmraid it shows vg0 - my Gentoo LVM volume, which I can't access; no authorization! Sadly, Google can't answer the question how to surf existing LVM partitions without CLI on Ubuntu.

BTW: Yet another stupid Debian legacy: When I'm installing DM Raid it wants me to say how I want to configure freakin' Postfix! Please leave me alone, I want dmraid, not Postfix! I've seen this Debian behaviour (requiring to configure something entirely else than what you're currently installin) more often and I am pretty fed up with it. Maybe I shouldn't have used 'apt-get'. Also, apt-get doesn't want to run "twice" in parallel, because it can't lock. Pretty stupid package manger if you ask me, not being able to run twice at the same time. I'm used to running 1-3 instances of portage consecutively without any problem, as long as "install lists" don't collide.

So when update is running, no chance of installing anything else at the same time.

Seems I can't point Nautilus to the "Computer" location as root to see my LVM partition. gksu Nautilus does work (btw why does gksu flicker the screen???), but then the "computer" location isn't available. Krusader is definitly better, why can't Gnome borrow the "Run Krusader in root mode" button?

Manually using CLI (I think it takes three clicks to start a terminal) doesn't help either; there's nothing in /dev/mapper and /dev/vg isn't there.

So I've mainly used Firefox on Natty. Not that bad, though I don't like the two bars in the top; it draws my attention away from the webpage. I'm on widescreen; so I'd rather have it on the left; but don't know if it's possible.

WebM fullscreen (Youtube HTML5) works pretty OK. Also, on the positive side, my scanner worked out of the box. Kudos for that! Plugins work pretty well, though I haven't tested many of those yet.

Installing flash really is a breeze and doesn't involve CLI at all, just point and click. Kudos again.

I as well as Steven didn't like the theme that much, especially I didn't like the dark menu bars.

So, as long as you don't have special requirements (like installing from SD / opening existing LVM partitions) I think it works pretty well. I plan to do a 'full review' for LXer, working on it!

Apr 26, 2011
10:02 AM EDT
Forgetting all the predictions of doom regarding both Unity and GNOME Shell, the fact is that this is somethng new, something under heavy development -- and it sure is different. And fortunately or not, different is what gets you noticed.

I can see this being a very compelling choice for new users a couple of releases from now (if they focus on polish over the next year).

Apr 26, 2011
11:54 AM EDT
I think they need to concentrate on two things:

1) More configuration options 2) More applets,

At present it looks like a usability regression to me.

Apr 26, 2011
12:05 PM EDT
Well, less is more I think.

These UNIX program names always baffle me:

If less is more so "less" is more than "more", than "most" is probably less than "less".

Or am I the only "most" user out here?

Apr 26, 2011
12:13 PM EDT
@hkwint, a quick perusal of their man pages shows that "less" is, indeed, more.

Apr 26, 2011
12:59 PM EDT
Just downloaded Natty nightly build. Used Starter Disk Creator on Kubuntu to install on USB. Booted on an HP Compaq 6910p, come up snappy with no issues. A notification indicated that wireless is available but wasn't connected. Clicked on icon in panel and selected name, entered password and wireless was connected. This post is from Natty using Firefox.

Actually I am impressed. It is snappy, clean and so far very functional. I believe it has great potential with average users who mostly use computers for reading mail, surfing the Internet, creating some office documents and playing computer games. It is ideal for tablets. I am sure, whatever apps. missing will be made available when final release is out.

The interface is very simplified, friendly and intuitive. I think any user will get used to it pretty quickly. On the other hand, having close, minimize, maximize buttons on the left side was not a good idea but, I guess users will eventually get used to it.

Left side icons panel is a good idea but would be better if made a little smaller and make room for more icons.

Over all, Canonical did a pretty good job.


Apr 26, 2011
2:22 PM EDT

Try the command line utility (written in python, I believe) image-usb-stick to load an iso to a usb stick.


I have had good luck with it.

The author is at: http://abock.org/

Apr 26, 2011
3:20 PM EDT
The Debian Squeeze "hybrid" install images can be copied to a USB drive with dd and will boot thereafter:


Apr 26, 2011
3:29 PM EDT
Steven: Thanks again. In my opinion, however, _all_ images should be able to be dd'd to USB and boot. But next time I want Debian from USB, I'll download that one.

ed: Oh, and of course thanks to numbr6x as well! UNetBootin did the job for me, but it's always nice to have a backup plan.

Apr 26, 2011
6:29 PM EDT
I've had varying degrees of success with UNetBootin and Fedora's USB utility (the name of which escapes me). Better to have the dd option, for sure.

Apr 27, 2011
1:48 PM EDT
Hans --

There's a "most" ?

Apr 27, 2011
7:30 PM EDT
> There's a "most" ?


man most:

most - browse or page through a text file


Apr 28, 2011
6:55 AM EDT
Yes there is, but most is more than more and less is more so more is less, so if most is more than more then I think it's less, but still more than less.

Apr 28, 2011
11:24 AM EDT
Hey Hans,

Why so complicated, it's a simple tried and true statement: "Less is More." So who needs the most? Not I said the weasel.


Apr 28, 2011
3:12 PM EDT
Indeed, I don't use 'most' either. In fact, I just found out my $PAGER is "less". Just funny.

In Belgium, there's a place called 'Lesswood' and one called 'Morewood', and this always pokes my intuition for nerdy jokes. Now if only someone could start a village called 'Mostwood...'.

Apr 28, 2011
8:05 PM EDT
Sounds to me like the old folktale...

What was it called... Oh, yeah...

Goldilocks and the Three Pagers.

Apr 28, 2011
9:28 PM EDT
> Goldilocks and the Three Pagers.

From Hans' comment, I was thinking of the three little pigs. Straw (less wood), twigs (more wood), but it breaks down at that point.

Apr 29, 2011
9:26 AM EDT
@Hans --

Now I understand...mostly.

You cannot post until you login.