XFCE and VFAT file names

Story: XFCE4 Desktop Application FinderTotal Replies: 9
Author Content

Feb 27, 2012
5:06 PM EDT
Pardon my ploy, is that the cat that chewed your new shoes?

Anyway, file names in vfat. Specifically, my camera.

I've been using KDE up to 3.5, now Trinity, pretty much for the last 12 years. There are some things I've grown rather accustomed to. One of those things is lower case letters on my pictures. This may seem trivial, but there's a twist that I'd like a pointer to help resolve.

When I use Xfce, automount works just fine to read my SD card from my camera, but everything shows up ALL UPPER CASE. So "img_2525.jpg" looks like "IMG_2525.JPG"

This may seem trivial, but several times I've had backups get messed up because a previously saved file "img_2525.jpg" is not recognized as already saved and I end up with duplicates.

Can someone suggest somewhere to look to why the same Debian Sid system, with Trinity and Xfce installed side by side, would have such a difference in how the removable media is mounted?

Feb 27, 2012
5:22 PM EDT
Maybe due to MS rattling the vfat-patent sabre?

Actually, both digital cameras I've used (Fuji, Olympus) showed their jpegs in uppercase when USB-mounted to my Mepis boxes, and Mepis 6.5 goes back to '06 when I doubt they were really concerned about that issue; I wrote a script to lowercase and MILdate-prepend the filenames partly for that reason. Is this a sudden thing for you?

In any case, there are image-dedupe scripts and programs out there; I wrote my own (.md5dedupe) that goes by checksums. Modifying it to only compare files whose names differ only by case should be simple. About the only thing I didn't do yet is make it recurse. If you want it to play with, /pm me.

Feb 28, 2012
3:22 AM EDT
this is likely due to the mount options. i think the default changed some time ago. to get vfat with lower case names it needs to be mounted with the option

as i remember, this used to be the default, but now the default is

it should be possible to change the option used somewhere in the automount config.

i am usually to lazy to figure out where to change it because i work on many different machines so i just manually remount with the right option whenever the problem comes up.

greetings, eMBee.

Feb 28, 2012
7:03 AM EDT
> this is likely due to the mount options...


Feb 28, 2012
10:08 AM EDT
Thanks, that gives me something to look for.

What surprised me is not that it's one way or the other, but that it changes from one desktop to another. I guess that means they're not using the same automount processes.

I should try it with KDE4 as well, just to be annoying about it.

One problem is that the /etc/fstab entries are dynamic, so I will have to find the "shortname=" in the scripts since there's no static options in /etc/fstab.

This Looks Like A Job For Grep! "$ grep */*/* shortname="


Feb 28, 2012
1:25 PM EDT
Sounds like it's probably a distro-specific thing, rather than anything to do with any desktop environment.

Feb 28, 2012
2:16 PM EDT
If it were distro specific, and I have both DEs installed at the same time, wouldn't they use the same automount scripts?

Anyway, interesting exercise in minutia.

Feb 28, 2012
3:10 PM EDT
I would not call this "minutia" if it's affecting the quality of a user's experience.

Feb 28, 2012
3:25 PM EDT
Gus, it's a rare woman who truly cares about the quality of a user's experience.

To expect that from programmers is absurd.

Feb 28, 2012
8:11 PM EDT
Is mtools involved?

There's mention of case in my mtools.conf file

# # uncomment the following line to display all file names in lower
# # case by default
# mtools_lower_case=1

Posting in this forum is limited to members of the group: [ForumMods, SITEADMINS, MEMBERS.]

Becoming a member of LXer is easy and free. Join Us!