All Raspberry Pi Devices Are Immune to the Meltdown and Spectre Vulnerabilities

Posted by hanuca on Jan 5, 2018 5:02 PM EDT
Softpedia; By Marius Nestor
Mail this story
Print this story

Just in case you were wondering, Raspberry Pi Foundation founder Eben Upton confirmed today that none of the Raspberry Pi devices are affected by the recently disclosed Meltdown and Spectre vulnerabilities.

Earlier this week, two major hardware bugs were unearthed in modern processors, affecting almost all devices powered by some CPUs from Intel, AMD, or ARM made in the past two decades. The Meltdown and Spectre vulnerabilities are considered the worst chip flaw ever discovered, putting billions of devices at risk of attacks.

In a lengthy post published on Friday, Raspberry Pi Founder Eben Upton explains what the side-channel attack is and how speculative execution works on modern processors, claming that all Raspberry Pi models are immune to the Meltdown and Spectre security exploits as they use ARM1176, Cortex-A7, and Cortex-A53 processors.

Full Story

» Read more about: Story Type: News Story; Groups: Raspberry Pi

« Return to the newswire homepage

Subject Topic Starter Replies Views Last Post
Good news... flufferbeer 1 1,151 Jan 6, 2018 9:18 AM

You cannot post until you login.