Debian alert: New emil packages fix multiple vulnerabilities

Posted by dave on Mar 25, 2004 3:30 AM EDT
Mailing list
Mail this story
Print this story

Ulf Harnhammar discovered a number of vulnerabilities in emil, a filter for converting Internet mail messages.

Hash: SHA1

- -------------------------------------------------------------------------- Debian Security Advisory DSA 468-1 [] Matt Zimmerman March 24th, 2004 - --------------------------------------------------------------------------

Package : emil Vulnerability : several Problem-Type : local/remote Debian-specific: no CVE Ids : CAN-2004-0152 CAN-2004-0153

Ulf Harnhammar discovered a number of vulnerabilities in emil, a filter for converting Internet mail messages. The vulnerabilities fall into two categories:

- CAN-2004-0152 - Buffer overflows in (1) the encode_mime function, (2) the encode_uuencode function, (3) the decode_uuencode function. These bugs could allow a carefully crafted email message to cause the execution of arbitrary code supplied with the message when it is acted upon by emil.

- CAN-2004-0153 - Format string bugs in statements which print various error messages. The exploit potential of these bugs has not been established, and is probably configuration-dependent.

For the stable distribution (woody) these problems have been fixed in version 2.1.0-beta9-11woody1.

For the unstable distribution (sid) these problems will be fixed soon.

We recommend that you update your emil package.

Upgrade Instructions - --------------------

wget url will fetch the file for you dpkg -i file.deb will install the referenced file.

If you are using the apt-get package manager, use the line for sources.list as given below:

apt-get update will update the internal database apt-get upgrade will install corrected packages

You may use an automated update by adding the resources from the footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody - --------------------------------

Source archives: Size/MD5 checksum: 602 1b5b16236b90e3b5c5dd1362e2a774db Size/MD5 checksum: 12492 dcfdd2e61e53595b5e7547725deb90ab Size/MD5 checksum: 214318 c9f6db6e90b5a6feb2d95cf71302aac8

Alpha architecture: Size/MD5 checksum: 139162 bef107a1a689d376da590dd63c85855d

ARM architecture: Size/MD5 checksum: 123982 a9be874dc7313689fd3c4983a88274f5

Intel IA-32 architecture: Size/MD5 checksum: 120678 979224cbb3c7eedb244ff0c32c2fcf5a

Intel IA-64 architecture: Size/MD5 checksum: 159672 727994fa7ca7c1f29bda179aa6c4caf1

HP Precision architecture: Size/MD5 checksum: 130684 d8ee92a6c252cf697d855272461601df

Motorola 680x0 architecture: Size/MD5 checksum: 117510 946d04b64b429f4effdc8b4fa0333959

Big endian MIPS architecture: Size/MD5 checksum: 130778 56c11718bfbab733906e1625a9cb1612

Little endian MIPS architecture: Size/MD5 checksum: 130640 e295c6fbc486e1434e550481e6a4c312

PowerPC architecture: Size/MD5 checksum: 127604 edd93d91f860b68ed5fb54feca725af2

IBM S/390 architecture: Size/MD5 checksum: 122696 5e3cdae4d6e3a586ec76d5e72db2e747

Sun Sparc architecture: Size/MD5 checksum: 127246 d76935af3c31b1b7d8f3915d51c825c6

These files will probably be moved into the stable distribution on its next revision.

- --------------------------------------------------------------------------------- For apt-get: deb stable/updates main For dpkg-ftp: dists/stable/updates/main Mailing list: [] Package info: 'apt-cache show ' and -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFAYd/hArxCt0PiXR4RAm5PAKCL6vA/ukztteQX+vylucaXqUMSUgCgkSJr etqrkZBwmDkz0OsXEtc70EQ= =jGEz -----END PGP SIGNATURE-----

-- To UNSUBSCRIBE, email to [] with a subject of "unsubscribe". Trouble? Contact []


» Read more about: Story Type: Security; Groups: Debian

« Return to the newswire homepage

This topic does not have any threads posted yet!

You cannot post until you login.