Weird link

Story: The First Personal Platform—for EverythingTotal Replies: 8
Author Content

Oct 04, 2013
5:32 AM EDT
It won't resolve properly from a comment post. Ridcully probably posted the right one. Here's a copy/paste of the URL from my browser window: %E2%80%94-everything


Oct 04, 2013
8:18 AM EDT
Unicode characters in the URL?

Come on Linux Journal, get with it.

Oct 04, 2013
8:47 AM EDT
That link doesn't seem to work either, djohnston. It looks like it has a space between platform and %E2 that shouldn't be there.

Oct 04, 2013
8:49 AM EDT
I sent a message to Scott over this particular link and I hoped that he might be able to resolve it before it hit the Home page. I tried every trick in the book to get the LXer software to accept the link to Linux Journal and it simply would NOT accept it. If you search on "The First Personal Platform - for Everything", you'll get the correct page listed in a Google search without any worries. Sorry about all that.

And yes jdixon, that "space" is the problem.....I just tried again using Firefox instead of Chrome, and got the same result. You can paste in the url without the space,but as soon as you save/send, the space somehow reappears. It's weird indeed and I personally would like to know just what is happening.


Oct 04, 2013
11:38 AM EDT
I fixed this so that the LXer link will now click through to the intended story, however, Linux Journal should really avoid using extended characters like the unicode long hyphen in their URLs. The php language has some nice text processing substitutions that can nicely sanitize an arbitrary string into a well-formed URL.

RFC1738 permits a limited set of encoded characters in URLs but also cautions about unsafe characters. In this day and age of sql injection and cross site scripting exploits, many web sites including LXer are taking the safe approach of permitting a specific set of user inputs rather than excluding a set of unsafe user inputs.

Oct 04, 2013
5:00 PM EDT
Quoting:I fixed this so that the LXer link will now click through to the intended story

I'm very curious, bob. How did you fix it?


Oct 04, 2013
10:00 PM EDT
It went something like this:

update news set url='http://...etc...' where id=192174;
In other words, "manual override".

Oct 04, 2013
11:09 PM EDT
Okay, thanks.

Oct 05, 2013
1:33 AM EDT
no support for unicode in urls? come on get with it!

as someone living in china i have no interest at all whatsoever to be forced to limit urls to an ascii character set. unicode support is not optional here, it's a hard requirement. get with the times please. there are other ways to make sure that there is no code injection.

that said, using a unicode long hyphen where a plain ascii minus would do is also not the nicest choice.

greetings, eMBee.

Posting in this forum is limited to members of the group: [ForumMods, SITEADMINS, MEMBERS.]

Becoming a member of LXer is easy and free. Join Us!