Trouble-shooting a VoIP Modem

Posted by Ridcully on Nov 7, 2013 8:19 PM
LXer; By Dr Tony Young

LXer Feature: 7-Nov-2013

This is a description of a long and involved process which shows how difficult and frustrating it can be to have a VoIP modem running, free of problems. Originally appearing in LXer forums, it has now been updated and expanded.

Introduction

I originally posted this on the LXer forums, but because it was suggested that the information was important enough to warrant an article on the newswire, I've revised the original text; and also added some additional text in a final section which was not included in the original forum post.

I stress that this article has nothing to do with the Linux operating system as such, and yet it has everything to do with my use of Linux. Nothing, in the sense that Linux does not come into it at all, but everything in the sense that if the problems with this modem had NOT been solved, then I would not be on the Internet and using my Linux equipment the way I want to, nor would I be able to use the much cheaper alternative of “voice over internet protocol” or VoIP. It also turns out that it was not just “one problem” but instead it was a “mixture of two problems”; a third later emerged, but that was definitely not part of the original situation. I offer the story here in the hopes that it may help anyone else who might have hit this "feedback loop" problem.



The Situation

LXer readers familiar with my original article (“How long is a piece of string”) on our home's solar power installation will know that our home runs on a “stand-alone” solar power system – we collect solar power during the day and store it in a battery bank for use at night, or during lower periods of sunlight. Our house is not DC powered; instead it runs on the Australian standard mains power of 240 volts AC, 50 Hz and this is produced by a Selectronics 3Kw sinewave inverter running from a 24 volt battery bank. This allows us to use standard shop purchased equipment which is far cheaper and easier to obtain than 24volt DC devices. The inverter system functions perfectly and we could not be more satisfied. Our home has never been connected to the power mains and we have a 3KVA petrol generator as a backup power source. It's rarely used.

Our home was first connected to DSL for broadband purposes some 8-10 years ago. We are at the 3km limit for efficient DSL operation, however we have never noticed any problems due to our distance from the exchange. My first modem was a Speedtouch 4-port modem which I still have. This relatively simple device runs perfectly and has proved invaluable in fault finding when our more complex present VoIP modem has had “hiccups”. For the Speedtouch modem, the incoming line is both split and filtered: the unfiltered half goes to the modem and the filtered half originally went to a standard telephone which was powered by the line voltages and also to a faxphone. The faxphone included a satellite mobile phone and loud speaker ability and due to its type of operation, the faxphone required power from the 240volts AC house system. I also want to stress here that the Speedtouch modem simply worked....it was (and still is) remarkably stable and extremely tolerant of “untutored users” such as myself. As far as I am aware, there was no problem with any of the telephone peripherals although very occasionally we might suffer a minor dropout due to a little instability on the line.

During summer, this area also receives violently active thunderstorms and our underground copper line has been subjected to some near misses from lightning strikes and we have heard our phones react to the induction effects. At the first sound of thunder, the modem is disconnected from the telephone lines.

With respect to the line instability, we did (a little over 10 years ago) eventually call in the services of Telstra, the telephone company who originally installed our lines and to whom we still pay rental. A company technician informed us that the 1984 cable was so “tired” that he was using a single and still working copper wire from each of two separate “pairs” in order to get us the two copper wires that constitute a complete working telephone line. (A “pair” is the term used by Telstra to describe the two copper wire pair that is needed for a complete telephone circuit). The technician also informed us that our own 100meter line from the nature strip pit badly needed replacement. Nothing was done. I also stress that at this stage we were still using the old faxphone. The dropouts seemed to be increasing and nothing we did seemed to solve them, so we just accepted that our line was damaged and subject to some irritating broadband problems but not with respect to normal telephone calls.

Our home is out in the countryside and about 170km by road from the state capital of Brisbane. As a result , most phone calls we make are not local calls, but instead are what we call STD (subscriber trunk dialling) or long distance. Because each call rapidly reaches its cap of $1.50 per call on a time basis, the results can be quite expensive and we eventually were persuaded by a friend to look at a cheaper solution.

About 5 years ago, we at last invested in a VoIP modem and were delighted with the results. All of our outgoing telephone calls went out through the VoIP broadband system and cost us a maximum of 12.5 cents per call to anywhere in Australia for unlimited time. The cost savings were dramatic and our monthly phone bill from Telstra dropped by about $70-100, so that within two months, the cost of the new VoIP modem had been repaid by our savings. Over a period of two years we have estimated very roughly that using VoIP has saved us a total of $1600-2200 and that is a sum I would rather have in my pocket than in the bank book of the telephone company.

That first Billion modem worked brilliantly for 3-4 years until disaster hit and our telephone line was subjected to a lightning strike before I could get to the modem and disconnect it. The VoIP relay was “fried”, but curiously, its standard DSL function remained fully operational. Needless to say, the damaged modem was replaced as soon as possible with a new and later model Billion 4-port VoIP modem and things seemed to be settling down to normal.

I'd like to add one little thing more to the mixture: I am also partially deaf and need as much support on a telephone as I can get. That original faxphone had adjustable volume and a loud speaker, but about a year ago, we knew it was reaching the end of its effective life span. Fax transmission to us became non-existent, so we no longer needed the facility. Earlier this year, after having a look at the available options, we replaced the old faxphone with a modern Telstra phone which had variable volume, a special filter for deaf assistance, a loud speaker and a satellite mobile phone. Naturally, the phone plugged into the house 240volts system. No worries – we thought, and indeed our first impressions of the new phone were marvellous. I could actually hear a telephone conversation easily.



The Billion Bipac 7401VGP 4-port modem running correctly. From left to right the green lights are power, two ethernet connections, VoIP line detected, DSL detected, Internet on line.



VoIP Modem Instability

For some time we had noticed increasing instability with the new Billion Bipac modem replacement. Drop outs, a refusal to power up properly, hunting for a suitable setting etc., and we were getting very irritated at what was happening. These modem crashes could occur randomly at day or night and at length they became so serious that our use of the internet was threatened, together with our use of VoIP for our long distance phone calls.

In those early stages, I first suspected the modem itself was at fault. As usual, earlier this year, we had lightning strikes and then several more after the new modem was installed, but as far as I knew the new modem had not been hurt even if the copper lines had suffered. Nevertheless, I thought it better to start with the device because a new one could be easily ordered and put in place. I rang the VoIP company and luckily reached a technician with some good common sense. He admitted it was very simple for him to sell me new one, but he was deeply concerned that it would behave exactly the same as the one we presently had and he strongly suggested that my first step should be to have the telephone line checked out. I took his advice and attempted to contact Telstra, our telephone company. There are a number of telephone operators in Australia, but the biggest and most widely used remains Telstra, and since it owns the copper lines which connect our home, we have remained with Telstra since we first occupied this house. Unfortunately, Telstra has outsourced its technical support to locations in India or SE Asia – to save money. To add to the difficulty, Telstra has now broken itself into two large sections: Telstra which handles telephone calls and services the lines, and Bigpond which handles all internet traffic (including emails and data flow) and the servers involved, but Bigpond does NOT service the lines.

Until you start the process, you can have no idea how difficult it is now to get Telstra to react to a call for help about a possibly faulty telephone, especially if the fault has anything to do with broadband. If you ring the general Telstra number, you get an automated answering service but at least it is spoken by a native born Australian. Once you have navigated the confusing list of options, you have a wait of at least 10-20 minutes while you listen to adverts and pretty awful music. Finally, you end up with an off-shore consultant and for a partially deaf person, this is almost impossible to deal with because of their accents. And then the endless loop begins: is it a line problem ? Yes, but it is not affecting the telephone, it is affecting broadband......Oh, you need Bigpond and it must be a computer problem.....but Bigpond does not handle the technical side of the actual telephone lines (Oh, yes, and Bigpond ONLY knows how to deal with Windows and Apple)........So Bigpond sends you back to Telstra...and round we go again. Feel like screaming ? I know I was close to it.

Eventually, out of sheer frustration and anger, I dropped out of this telephone reporting loop and I sent a direct email to Telstra, outlining the problems and requesting technical help to check the line. Amazingly, I got results although the first response was via a SE Asian technical consultant who from somewhere outside our country was able to set up a local technician's visit to check our lines. The tech arrived, found there was water at one of our junctions and removed it. He then tested the line and certified the line as being well within all standards. He was also amazed at just how much speed I was getting on the line. Okay....first problem solved. Hopefully.



The Solution

But the modem instability remained. Our device is a Billion Bipac 7401VGP 4-port modem with full VoIP capability. Erratically and at any time of day or night, it would lose the DSL line and then begin to hunt and would go on like that, if left, for hours. The modem symptoms included the power up light remaining amber while the rest of the front indicator lights went through an endless cycle of “marching across the face of the indicator display”. Alternatively, the power and user connection lights remained stable, but the DSL, internet access and VoIP indicators would all turn off and the DSL indicator would then show that the modem was trying to re-establish a connection. Sometimes this was rapid, other times it was very prolonged......We at first suspected anything.....spurious signals from the inverter, something my son Peter was doing with his Alienware gear (sorry Peter, it wasn't you - ever), a defective modem, a filter powerboard playing up......we tried isolating things bit by bit, but the problem remained.

It so happens that before we got our present SA32 Selectronics sine wave inverter we had a much older Selectronics inverter which we proved actually was producing spurious signals on its sinewave output and Selectronics sent us a very nice filter unit (free of charge). It's only about 140watt capability, but it could filter out the power going to our new digital TV set at that time. The television reception problem was that we could receive analogue signals but the TV set scrambled if we tried to use it for digital reception. With the Selectronics filter in place, that TV set was able to receive digital signals properly. We realised the older inverter was past its useby date, and did a deal to get our present inverter which produced a clean output and the TV worked without the filter. Because it was a trial device, Selectronics did not want either payment or return of the filter unit, and so it has been sitting in the storage drawer ever since.

Our present new digital TV works perfectly, so I reasoned that it was unlikely that the inverter was the cause of the problem, but something, somewhere was upsetting the Billion modem. On a hunch, I put the filter unit in series with the supply to the new Telstra phone........and bingo. Except for one very unusual hiccup, our modem has been rock solid now for the past week, and will probably keep on going the same way. Somehow that new telephone produces signals that form a feedback loop through the house 240 volt power lines and upsets the Billion modem and that filter pack totally blocks those spurious signals. Also, looking back on it, it is also likely that previous instability with the earlier faxphone was for the same reason. Powered telephones with VoIP modems have hidden traps and I seem to have uncovered this particular one quite well.......and solved it thank goodness.

There was one last minor hiccup in getting back on line and I suspect I was the cause. During one of the periods when the modem was operational, I entered as administrator and checked a couple of things out. I didn't think I had touched anything, but I am not sure. Anyhow, for some reason, I had to turn the modem off for half an hour or so, and afterwards, I turned the modem on and powered up with no problem. The sequence was perfect:: power on, computer connection confirmed, DSL line present - and a “blankety-blank” permanent red light for the internet. The solution to this little mess was again to revert to the Speedtouch modem and a google check showed that in all probability the modem had lost my user name and password......I examined the appropriate place in the modem's settings, and it was so.......re-inserted them and once more the modem came on line.



The Telstra Phone with Selectronics power filter installed.



A Hidden Trap

You might think nothing else could happen, but it did. Three days after I thought I had a rock solid modem, I came out first thing in the morning to find the device in “hysterical mode” again. Okay.....disconnect Billion, re-attach Speedtouch.....But the Speedtouch modem also refused to boot up and remained firmly with an orange power light which turned off at regular intervals. Could it be the power system ? I turned on the study light, which instantly came on.......Something else then - and I turned the study light off.

The answer was a sheer fluke in observation. I went to see if my wife would like a cup of tea and in so doing passed the power board that sits behind the TV, dvd Player, etc. and noticed that its amber power light was flickering. It would come on, then go off, flash a couple of times, and then come on again, and repeat the cycle. I had not seen this pattern with the powerboard in my study because the amber power light on that particular board is defective, but as soon as I saw the sequence, the answer came thundering in: “The inverter cannot find sufficient load to remain on permanently and is reverting to “check if a load is present” mode. I have a remote sensor to the battery regulator and inverter loads in the study and a quick check with this unit confirmed what was happening. I turned the study light on to give a steady load, and then rebooted the Speedtouch and had internet connection established within two minutes. The Speedtouch was then removed and the Billion took its place and again, internet connection was established very quickly.

The reason for this situation is of course, that we are extremely careful with power consumption, and all our appliances are chosen for their low power usage and efficiency. But there is a limit and we simply got tooooo miserly with our steady state power use and the inverter lost its triggering load.

Needless to say, a trip to the inverter shed later on that morning ensured that the inverter settings were changed to “ON, Constant”. I'd also mention that while it might be possible for this situation to have contributed to the modem problem, it certainly wasn't the main cause.....Many of the modem crashes occurred at day or night when the house loads were triggering normal power from the inverter. Nevertheless, this additional small hiccup makes you realise just how much you need to monitor your system. If the amber power light on my desk power board had been functional, I'd have recognised the problem immediately and need I say that this powerboard has already been replaced ? For an inverter system, those power indicator lights are crucial, because they are diagnostic of the inverter's power output status.



Another Feedback Loop

In case there might be readers who doubt the possibility of a 240 volt feedback loop, this is the second time I have struck a similar situation. A few years ago, after I transferred totally to the much less power hungry laptop instead of a desktop, I still had a spare desktop hdd which I decided to use as a back up storage device. I ran it in the usual caddy with a power module that plugged into our 240 volt system and an output/input usb connector for the computer. It seemed to work perfectly and I began to use it......BUT.......In order to use the backup hard disk drive, I plugged it into the house power then waited while the hdd spun up to correct working speed and the green light appeared; I then inserted the usb plug into the laptop which of course, was also running on the house 240 volts via its battery recharger module. The moment the usb plug was inserted into the laptop, the internet modem crashed, and I stress that at that time it was the very stable Speedtouch modem. I confirmed this crash several times because I just didn't believe it when I saw it for the first time. You could get around it by unplugging the laptop from the 240 volt recharging supply, but it just wasn't worth the hassle and so now I have the small laptop hdds and the little usb caddies that they require......No problems.

And there we are. I hope everyone enjoyed the saga........Believe me, it is so nice to see those green lights on the modem all staying steadily where they should be and blinking during data transmission. Dr Tony Young.

Return to the LXer Features

Subject Topic Starter Replies Views Last Post
Solar penguinist 5 611 Nov 9, 2013 4:01 AM

You cannot post until you login.

LXer

  Latest Features
Scott Ruecker (Phoenix, U.S.) : Interview With Richard Kenner of AdaCore
Aug 29, 2014

Scott Ruecker (Phoenix, U.S.): LXer Weekly Roundup for 24-Aug-2014
Aug 24, 2014

Carla Schroder: Test Sites for Heartbleed OpenSSL Vulnerability
Apr 09, 2014

penguinist: Better Than a Quad-Head Display: My Adventures with "4K" 2160p and Linux
Mar 31, 2014

Dr Tony Young: Replacing KDE4 with Xfce
Mar 07, 2014

Dr Tony Young: Removing/Disabling The Semantic Deskop in KDE4 Running on openSUSE 13.1 Part 2
Feb 18, 2014

Dr Tony Young: Removing/Disabling The Semantic Deskop in KDE4 (and firing up Thunderbird) Part 1
Feb 08, 2014

Dr Tony Young: KMail Complexity - and a little Patience
Jan 26, 2014

Carla Schroder: Linux Nerd New Year's Resolutions
Dec 29, 2013

Carla Schroder: Fedora 20 Released With New, Newer, and Newest
Dec 17, 2013


View all

  Search Features

Search LXer Features:

[ Copyright © LXer | All times are recorded in Central Daylight Time (CDT) ]

[ Contact Us | Privacy Policy | Terms of Service | About us | rss | Mobile ]

Login